Earlier today, some customers experienced slower response times due to an issue with our cloud provider. We’ve rebalanced our services away from the affected cloud provider's data center, and services are running smoothly again.
Thank you for your continued patience.
Posted Oct 27, 2025 - 15:10 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 27, 2025 - 14:39 PDT
Update
Our Google Cloud Provider is currently experiencing an issue in one of their data centers, which is causing increased latency across some services hosted within that facility.
We want to note that our infrastructure is deployed across multiple data centers to ensure redundancy and high availability. Currently, only a subset of services within the affected data center are affected.
Our engineering team is actively monitoring the situation and working with our Cloud Provider to mitigate the impact. We will provide updates as more information becomes available.
Posted Oct 27, 2025 - 13:57 PDT
Investigating
We are investigating an issue where users are experiencing intermittent workflow errors when using the Web app.
Our engineering team is actively working on providing solution as soon a possible. We apologize for any impact this causes to your business and will keep you updated on our progress.
Thank you for your understanding.
Posted Oct 27, 2025 - 13:34 PDT
This incident affected: Platform and Clinical (EHR).