Experiencing Technical issues with calling support

Incident Report for Tebra

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 13:30 PDT

Investigating

Service Disruption: We’re currently experiencing an issue impacting our Support team’s ability to receive and manage phone calls. Our team is actively monitoring the situation and working to restore normal service as quickly as possible.

If you need support, please use the Customer Portal to submit a case or respond to an existing case. We’ll provide updates as more information becomes available.

Thank you for your patience while we work through this issue.
Posted Sep 16, 2026 - 06:44 PDT
This incident affected: Phone & IVR.