We currently investigating an issue where there are multiple messages listed within Message Center

Incident Report for Tebra

Resolved

This incident has been resolved.
Posted Apr 22, 2026 - 14:49 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 22, 2026 - 09:30 PDT

Investigating

We are investigating an issue where users are seeing a large amount of messages within the Message Center.

Our engineering team is actively working on providing solution as soon a possible. We apologize for any impact this causes to your business and will keep you updated on our progress.

Thank you for your understanding.
Posted Apr 22, 2026 - 09:28 PDT
This incident affected: Clinical (EHR) and Billing (PM).