Currently investigating an issue where users are unable to log in to Web App and PM app.

Incident Report for Tebra

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 18:18 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2026 - 18:17 PDT

Investigating

We are investigating an issue where users are not able to log in.

Our engineering team is actively working on providing solution as soon a possible. We apologize for any impact this causes to your business and will keep you updated on our progress.

Thank you for your understanding.
Posted Jul 22, 2026 - 17:44 PDT
This incident affected: Platform, Clinical (EHR), and Billing (PM).