We are currently investigating an issue where some users experienced latency within the Web application

Incident Report for Tebra

Resolved

The issue with navigation modules and the calendar is resolved. Our team continues to monitor the system, and services are fully operational. We understand these issues disrupted your work and apologize for the inconvenience.
Posted Mar 19, 2026 - 09:22 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2026 - 08:56 PDT

Investigating

We are investigating an issue where some users experienced latency or incomplete loading of the Calendar.

Services appear to have returned to baseline. Our engineering team is actively looking into the cause. We apologize for any impact this causes to your business and will keep you updated on our progress.

Thank you for your understanding.
Posted Mar 19, 2026 - 08:53 PDT
This incident affected: Clinical (EHR).