Customers unable to access Renew Medications screen

Incident Report for Tebra

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 13:03 PDT

Investigating

We are currently reviewing an issue where customers are reporting not being able to Renew medications and/or not being able to load the Renew medication screen.

Our engineering team is actively working on providing solution as soon a possible. We apologize for any impact this causes to your business and will keep you updated on our progress.

Thank you for your understanding.
Posted Apr 09, 2025 - 15:10 PDT
This incident affected: Platform and Clinical (EHR).