Scheduled Database Maintenance - May 1st, 2025 at 7pm to 9pm PT

Scheduled for May 1, 19:00 - 21:00 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 21, 2025 - 08:56 PDT

Scheduled

On May 1st, 2025 at 7pm to 9pm PT we will be conducting scheduled database maintenance.

During this time active users may experience (description of impact i.e. "intermittent latency and/or temporary unavailability of the database" or "Tebra Platform, Tebra Desktop (PM) and APIs will be unavailable").

Thank you for your patience and understanding as we complete this maintenance work.
Posted Apr 21, 2025 - 07:30 PDT
This scheduled maintenance affects: Platform, Clinical (EHR), and Billing (PM).