We are currently investigating an issue where some users maybe experiencing an error when trying to access PM and/or Web App.

Incident Report for Tebra

Resolved

This incident has been resolved.
Posted Jan 26, 2026 - 17:06 PST

Monitoring

We appear to be in recovery at this moment. But will continue to monitor.
Posted Jan 26, 2026 - 16:00 PST

Investigating

We are investigating an issue where users are not able to access the PM and/or Web App

Our engineering team is actively working on providing solution as soon a possible. We apologize for any impact this causes to your business and will keep you updated on our progress.

Thank you for your understanding.
Posted Jan 26, 2026 - 15:39 PST
This incident affected: Platform and Billing (PM).