We are currently investigating an issue regarding intermittent latency when using the Web application

Incident Report for Tebra

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 12:29 PDT

Update

We have identified the issue and have made updates to stabilize the application. We will continue to monitor the system. Thank you for your continued patience.
Posted Jul 22, 2026 - 11:52 PDT

Investigating

We are investigating an issue where users are experiencing latency when accessing Notes and/or being kicked out of the application.

Our engineering team is actively working on providing solution as soon a possible. We apologize for any impact this causes to your business and will keep you updated on our progress.

Thank you for your understanding.
Posted Jul 22, 2026 - 08:45 PDT
This incident affected: Platform and Clinical (EHR).