We are currently investigating an issue where users are experiencing intermittent log in errors and/or Opening Clinical Notes

Incident Report for Tebra

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 15:09 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 31, 2026 - 12:52 PDT

Update

Clinical Notes are now accessible, however we are still seeing latency upon opening.
Posted Aug 31, 2026 - 11:50 PDT

Investigating

We are currently investigating an issue where users are experiencing intermittent log in error and/or Opening Clinical Notes

Our engineering team is actively working on providing solution as soon a possible. We apologize for any impact this causes to your business and will keep you updated on our progress.

Thank you for your understanding.
Posted Aug 31, 2026 - 10:22 PDT
This incident affected: Platform, Clinical (EHR), and Billing (PM).