We are currently investigating an issue where users are not able to access Patient Notes.

Incident Report for Tebra

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 14, 2026 - 09:29 PST

Investigating

We are investigating an issue where users are not able to access Patient Notes.

Our engineering team is actively working on providing solution as soon a possible. We apologize for any impact this causes to your business and will keep you updated on our progress.

Thank you for your understanding.
Posted Feb 14, 2026 - 08:53 PST
This incident affects: Platform and Clinical (EHR).